Your phone: BlackBerry 9300

Download Galaxy 9.0 [16+] 

If current version 9.0 works incorrectly on your phone, select one from below:
Version 9.1

Press here if you want to select another phone.